Dreams of Thought

Are dreams thoughts… or are thoughts dreams..

RSS Feed

Installing PostGIS on Ubuntu 13.04 Raring Ringtail

2 Comments
Posted by Anirudh on August 2, 2013 at 6:49 PM

It's as simple as
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get install postgresql-9.1-postgis-2.0-scripts

You might see alternate instructions asking you to install Sharpie's PPA, but it works only for Ubuntu Precise. The instructions in the PostGIS trac wiki is also broken ‐ you will get an error like so :
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postgis : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
This problem has been raised and a solution found in the PostGIS Trac Issue tracker. The first two lines are what needs to be done.
Filed under code
You can leave a comment, or trackback from your own site.

2 Comments

  • On September 10, 2013 at 9:58 PM Jim Bouse said

    Thanks! This got me going.

  • On April 10, 2014 at 11:32 PM Mateusz said

    Thank you! Your post was very helpful for installing postgis.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>