Are dreams thoughts… or are thoughts dreams..
It's as simple as
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable sudo apt-get install postgresql-9.1-postgis-2.0-scripts
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: postgis : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages.This problem has been raised and a solution found in the PostGIS Trac Issue tracker. The first two lines are what needs to be done.